PDA

View Full Version : Problem with emitters.



Xuiryus
11-12-2008, 01:27 AM
Ok first off.

I created an object on a seperate level to test it worked fully.

It's a conveyor belt style object with emmiters used a platforms running along a seris of motor bolts. Now while testing this on my seperate level it worked perfectly no bugs in the slightest.

However I insert it into my map and then add another 3 of the object and all of a sudden things go wrong... Some of them work perfectly, others barely work and the rest don't work at all, the emitters just get stuck...even though the carbon copy others work 100%.

I've tried setting the emitters to less at once to see if maybe I have too many on screen but to no avail.

Can anyone shed some light on this topic?

RAINFIRE
11-12-2008, 01:32 AM
ok here is a thought, do you have emmitters on every section? if you do then that is a big no no because it mostlikely will not work very well or even work at all

second please use grid mode when lining up the sections because some of them can intersect on accident or be the wrong spacing and there for the motor bolt section does not work very well and it is hard to transfer that platform from one section to the next

hope this helps!

Cheers!

chillum007
11-12-2008, 01:44 AM
did u change the size of the conveyor belt object before placing it?

I have found that mechanical objects sometimes don't work as they should if you re-size them (though I have only had a problem with making them smaller, so far).

Hope this helps. Cheers!

docpac
11-12-2008, 02:23 AM
I think Rainfire is on the right track. If you have emitters working on all three and they're are supposed to pass the platform from one section to the other, the platform may be preventing certain emitters from even firing.

Xuiryus
11-12-2008, 01:55 PM
I feel I may not have explained this properly.
So here goes' again.
To get a better thought on what this object is, think of the conveyor belt on one of the last levels in the wilderness. (Bunker maybe?) I think it works similarly to that although the platforms are on a much smaller scale.

The emitters spawn ontop of the motors (all of which work perfectly) they move from right to left and fall into an area none visable by the player (at this point they disappear) They seem to randomly get stuck sometimes in the middle of it, I have no idea why this is I've checked and rechecked the spacing between the motors to see if they are touching or what not, no problems in the slightest.

The emitted objects DO NOT pass to other platforms/emitted areas they simply fall into a little hole and disappear.
If anyone feels they can solve this problem and would like to have a look at the actual object in question feel free to add me on PSN and I'll talk to you about it when I get home from college.

Thanks for the suggestions so far.