PDA

View Full Version : Respawning on Custom Objects + Black Bar on Pictures?



Plokster
01-17-2013, 10:28 PM
Alrighty, so I'm having trouble with 2 problems:

1. I'm making an entirely custom track and it's almost perfect... except the respawning is going a little wonky. When someone gets hit by a weapon or falls off, they get spawned inside the custom objects. I've tried putting terrain directly beneath it (just enough so it isn't visible), yet you still get stuck inside.

Is there a way to make it so they always spawn on top of custom objects?

2. I'm having problems getting pictures for my levels properly. After I take a picture and set it as the track icon, I get these black bars along the top and bottom:

https://lbpk-production.s3.amazonaws.com/player_creations/28057/preview_image.png

It's not really that much of a problem, but it does look unsightly.

Any help is greatly appreciated, thank you!! :)

Rogar
01-17-2013, 11:01 PM
One way to force spawns is to link a reset sensor to a reset gadget set to a specific spawn point. I've got a copyable example: https://karting.lbp.me/v/3319

RocketHotdog
01-18-2013, 03:49 PM
2. I'm having problems getting pictures for my levels properly. After I take a picture and set it as the track icon, I get these black bars along the top and bottom:

https://lbpk-production.s3.amazonaws.com/player_creations/28057/preview_image.png

It's not really that much of a problem, but it does look unsightly.

Any help is greatly appreciated, thank you!! :)

are you taking the picture during your cinematics? because it does that...

Plokster
01-18-2013, 07:42 PM
@Rogar

Thank you, that worked well. If there's too many though, it causes everyone to reset at the beginning of the race. Don't know why.

However, I did set up only about 3 (which works) and I put force field directly under the spots that were having the most trouble. Works likes a charm, now!

@RocketHotDog

Nope, I always take them while editing.