View Full Version : Story Mode bridge glitch (Manglewood Swamp) Need urgent help!

12-04-2014, 03:02 AM
So I was playing through the story (on PS3 version btw) when I unlocked Oddsock, I was told to cross a bridge to the right but when I got there... The bridge isn't there... I have tried everything I could to bring the bridge back but nothing worked. I need help on what to do! Please! I really love the game but if I'm unable to AT LEAST continue the story, then I'll just give up on something awesome.:frightened:

12-04-2014, 03:09 AM
A patch just went live in the UK within the hour that acknowledges what you're experiencing. Not sure when it's going to hit U.S.

This was in the patch notes...

•A number of improvements have been made to the Dynamic Thermometer functionality of our Adventure mode’s hub levels to improve functionality and general stability. This includes the saving the state of Manglewood Swamp with the rare “broken bridge” occurrence.
Note: If you have encountered this Manglewood Swamp issue. You will need to delete your Adventure Save Data since the Manglewod Swamp level will be saved in this broken state.

12-04-2014, 03:23 AM
I was getting really worried there for a sec, Thank you so much! :D Also I got an update a bit ago so that might be the one

12-04-2014, 04:58 AM
Patch just released talking about this exact issue. Basically if you can apply the patch and reload your game without this bridge issue you're good, but if the issue persists, you need to delete your saved game.