View Full Version : Piston problems since LBP 2

12-09-2014, 12:11 PM
This problem has been a issue in a Very long time now and i dont see why this thing is even in the game. When im using a piston you know wanna add a cool contraption in my level you dont want players to see the piston or the room where the object is being pistoned into. But whait i cant do that because everytime i put some walls around a block with a piston on the block will at some random point be stuck between the walls like there isnt enough room to move wich there sould definatly be since it moved fine before that! EVEN when im using Grid shapes the object will somehow get stuck at a random point please Sumodigital Remove this annoying annoyment:(!

12-09-2014, 02:29 PM
If I have understood the issue correctly....

Compher has a great Tutorial on how to avoid this (can't recall which, but the one where he shows building in sections and using the grid). Something I have done ever since LBP 1. Just like in real life you need to shave a minor bit off both the block and the walls so you avoid friction.

12-09-2014, 06:18 PM
Alright wiil try that thanks

Mighty Mac
12-11-2014, 08:35 AM
If you use pistons in mechanics (not using them as a platform like a lift) you have to put a material tag on it and drop the friction down to zero, it will help it from getting stuck, and also never use 100% power, if it does get stuck it will just break. But over all, avoid using pistons as much as you can. I use a custom microchip I made, basically it uses a up-mover, down-mover, and a gyroscope (moving both directions). To stop the block, you place a block of white matter with zero opacity and tagged-object-collision only on a physics tag. I've never had any issues with anything iv'e used it on. If you don't want to go thought the hassle, the use the rail tool with the setting set to hidden. I only started messing around with it a few days ago but I haven't had any issues with it yet. If you have the hook hat in the map and you want the rail that your object is sliding on to be visible, make sure you set it to the "no hook-hat" mode.